Back to overview
Downtime

Degraded Performance

Jan 05 at 06:45pm NZDT
Affected services
xanzhu.com

Resolved
Jan 05 at 07:12pm NZDT

Reviewing Performance

Updated
Jan 05 at 06:59pm NZDT

Enabled Maintenance Mode.

Created
Jan 05 at 06:45pm NZDT

Investigating slow performance